fkm blog

software開発に関することを書いていきます

AdMobのライブラリの更新

今まで, AdMobはjarをぽいっとlibsにいれて使ってましたが, 8月あたりからその方法が禁止になるようです.

今後, AdMobを使いたい場合はGoogle Play Serviceに入っているAdViewなどを使わないといけません移行方法はこちら

で, 今直面している問題.

Google Play Serviceを入れると, minSDKVersionは9以上にしないといけない

言い換えると, 今後, AdMobで収益化をしたいならAndroid 2.2のサポートはさせないということ.

レアではあると思いますが, アクティブユーザーにAndroid 2.2以前がそれなりにいる場合は注意